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1.1 Connecting to XecliP-Server 
You have to connect to a Xeclip-Server before joining a pair programming session. Please 
choose XecliP > QuickConnect from the menu or select the button from toolbar. Then you 
will see the following connction dialog. 

  

The following Settings are required: 

Host: server name,  
Port: server port,  
Username: your user name  
Password: and your password.  

The password can be saved. It will be saved on your local harddisc in a encrypted way. (Saved 
passwords are stored on your computer in a file that is difficult, but not impossible, for an 
intruder to read.) 

You can load the setting from history using the dropdown menu, if you have been to this 
server before. The history keeps track of the last 5 settings you used.  

A connction to XecliP-server will be established after pressing the "Connect"-button. 
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2.1 UserView 
The User View starts automatically by using the XecliP Perspective if you connect to a server. 
It can be opened manually by Window > Show View > Other > XecliP. 

As soon as you are connected to a server, the UserView shows in a tree structure the server 
with his IP-adress, if created your user groups and all online users with their own icons, names 
and their status (online / in session / not available /busy). In the status line of the view you will 
see yourself with your login name, your icon, your status and in case you are just in a session 
the icon correspondig to your role. 

UserView: 

 

Status of users: 

online: The user is online and can be invited to a pair programming session.  
busy: The user has logged in, but his status is "busy" at the moment. This happens for 
example when the data transfer begins before a session start.  
not available: The user has logged in, but changed his status to "not available" at the 
moment. He can´t be invited to a pair programming session. To switch your own status 
see "Change your own status".  
in session: This user has joined a pair programming session (Session view) and can´t be 
invited to another session.  

If a user disconnects from the server (his status would be “offline”) it will disappear from the 
tree. 

 
 
 
 
 
 
 
 
 
 
 
 
 



Groups: 

Users can be individually grouped in the User View. Groups are displayed in a blue color. All 
group members are shown under the appropriate group. In case one user is a member of more 
than one group, he will be shown several times (one time in each group). Groups can be added 
or edited at the XecliP preference page by a right click on the server or a group (“Organize 
Groups“) or Window > Preferences > XecliP. For more informations please see XecliP 
Preferences. 

 

The user view is also be used to choose a user to invite him to a pair programming session. To 
start a session see the instructions below. 

Short explanation of the functions in this UserView: 

1. Invite another user to a session 
To invite another user (his status must be “online”) you can start the session definition dialog 
with a right click oder a double click on this user in the tree. There are some conditions to start 
a pair programming session. 

2. Answer to an invitation 
If you are invited to a pair programming session by another user this will be shown by a 
yellow background color at this user. You can start the invitation dialog by a right click or a 
double click on the inviting user. 

3. Change your own status  /   
If you are busy at the moment but don´t want to log out from the server, you can change your 
own status from “online” to “not available” by using the status button in the user view´s 
menue bar. The button´s color will change from green to red. 

As long as your status is “not available”  you won´t be able to be invited to a session. If you 
want to swich your status back to “online”  please press the status button again. His color 
will change to green and your status change to “online”. Please note: This funtion is disabled 
if you already joined a session. 

4. Search for users by the user filter   
By using the filter button in the user view´s menu users can be sorted by status or name. If you 
want do find a special user choose the option “Search for a special user”, enter his name in the 
text field and press “OK”. If you search for users with a special status choose one of the three 
other options and press “OK”. A user name is not required in this case. The user view will 
show you all users according to your search options. To restore the user view´s state please 
press the filter button again and. 



 

5. User profile input dialog   
By using the  button in the user view´s menu users can start the user profile input dialog. 
Within this dialog the user can give some details about his person (name, address etc.), 
personal abilities and name of projects, in which he has worked. The user can also load a 
picture from himself (Create a user profile). 

The abilities are necessary and helpful to get some more informations about the user and later 
this statements help to find a partner for a common procjet. For example you can search with 
the session wizard in the the session view for a special user. 

6. Accept a visitor to participate in a session 
If a visitor wants to participate in your session, this will be shown by a flashing green 
background color at this user in the User View. The driver can accept or deny his request by a 
right click on the user. 



2.2 UserProfile Dialog 
By right-click on a user in the context menu in the user view the user can look for an user 
profile of another user. The user is able to see the details from the user containing name, 
address etc. and if the user has loaded a picture, the user can also see a picture of the user: 

 

By using the UserProfile InputDialog the user can fill in his own profile (Create a user 
profile). 

 
 
 
 
 
 
 
 
 
 
 
 



2.3 SessionDefinition Dialog 
After you have connected to the server (Connect to Xeclip-Server) you can choose a user for 
the pairing session. There are three possibilities to open the SessionDefinitionDialog:  

1. Choose a user in the UserView (UserView) and right-click. Choose "Invite as navigator to 
session". The SessionDefinition dialog will appear. 
2. Choose from the menu: Xeclip > New session. The SessionDefinition dialog will appear. 
3. Choose a user at the Session Wizard Result Dialog (SessionWizard). After the dialog gets 
open you can choose a xp-partner from the combo box. After pressing the OK button the 
SessionDefinitionDialog will appear. 

 

In the Session Name field, type a name as the name of your new pair programming 
session  
In the Session Description field, type a brief description for the task of the new session 
Select the project from the combo box Please select project which you want to use for 
your session.  
Depending on which method you have chosen (1., 2. or 3.) to open the dialog, you have 
to select a user from the Please select User combo box. In the first and third case the 
user will appear in the combo box field, otherwise you have to select it by yourself.  
Check the first check box, if you want to allow visitors to join the session without 
confirmation by the driver.  
Check the second check box, if you want to record the session. 
Attention: Do not use this function if you have a internet connection witch low 
upstream speed on driver side or the navigator has a internet connection with low 
downstream speed. The whole project data of the session will be transferred to the 
server and from server to navigator. So it can take much more time to setup the session. 

Click Connect button to send invitation to the selected user. 



2.4 SessionWizard 
You can start the SessionWizard bei pressing the SessionWizard button at the SessionView 
toolbar (SessionView). With the session wizard a user can search for an user with special 
skills or who is working at a particular project. 

 

At the first page the user can choose if he want to search for users with special skills or for 
users who are working at a particular projects. With the third searching citeria the user can 
look for both (skills and projectnames).  

After the user has selected a radiobutton and pressed the Next button, the next wizard page 
appears. On this page the user have to select/enter further details. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



Wizard page "Search for user skills": 

 

Wizard side "Search for user projects": 

 

 
 
 
 
 
 



 
Wizard page "Search for both (user skills and projectname)": 

 

After pressing the "Finish" button the request will be send to the server. After a few seconds 
the result page will appear. All users matching the searching criteria will be shown and the 
user has the possibility to start a new session with one of the found users. Otherwise the user 
can press "Retry" and search again or press Cancel to close the dialog. 



2.5 SessionView 
You can start the SessionView by using the menu Window > ShowView > Other > XecliP > 
SessionView. Otherwise the view gets open after initializing a session. 

The SessionView shows in a tree structure all actually sessions and all users, who are in this 
sessions. By means of the icon in front of the username you can see which role the individual 
user has in the session. The user can be in a role as a navigator, a driver or a visitor.  

SessionView: 

 

In the menu are two icons: 

 session wizard  
 sessionFilter  

With right-click on the session folder (e.g. "SessionWizard") a session popup menu gets open. 
It contains "join session as visitor", "leave session" and "close session". Only driver and 
navigator are able to close their session. A dialog will get open and aks if he/she really wants 
to close the session. 

With right-click on an user (e.g. "Dominik" ), a user popup menu gets open: 

 

Short explanation of the functions in this SessionView: 

1. With switch role - accept (SwitchRole) the users can accept a change of the roles 
(driver/navigator). 
2. With right to speak - accept the driver can accept a speech request from visitor  
3. With right to speak - reject the driver can reject a speech request from visitor. 
4. With rigth to speak - revoke the driver can revoke an already given speech right. 
5. The SessionWizard will start a dialog. The user will be guided through the dialog to search 
for users and start a session (Session Wizard). 
6. The SessionViewFilter: This filter has the function to search for an user or a session by 
name. You just have to type the name of the session or the user (case sensitive!) and select 
"search for session" or "search for user" and press OK. The SessionView will show you the 
found session / session with the user you have searched for.  





2.6 XecliP Java Editor 
For the XecliP-plug-in the XecliP Java editor is the default editor to edit Java documents. If 
you are not in a XP-session you will not notice any difference to the ordinary Java editor of 
Eclipse. The editor provides all specialized features the Eclipse user knows from the Java 
editor, amongst others: 

syntax highlighting  
content/code assist  
code formatting  
import assistance  
quick fix  
integrated debugging features  

After initializing a pair programming session (SessionDefinitionDialog), it is important to use 
the XecliP Java editor. If the driver opens a new Java file, which is part of the shared 
project of the session, the same file is opened in the XecliP Java editor at the other XP-
partners; on navigator or visitor side. The most common way to invoke the XecliP Java editor 
is to open a Java file from the Navigator or Package Explorer using pop-up menus or by 
selecting a Java file. While the opening of the editor is in process at the XP-partners side, the 
driver sees a progress monitor, which will disappear when the editor is open at all XP-
partners. 

While the pair programming session is running, all changes made on the driver side will 
appear on the XP-partner side. If the role of the XP-partner (driver - naviagtor) changes 
(SwitchRole) the new driver get the control to edit the files. 

At the moment the following events are supported by the XecliP Java editor:  

The driver opens a new Java file, so the editor will be opened at XP-partner side as well. 
The driver saves editor content; the file will be saved at XP-partner side, to keep the 
source code consistent.  
(A navigator or visitor can not save a editor file while the session is running.)  
The editor window is closed by any XP-partner, the file will be closed at all other XP-
partners too.  
The driver changes to another editor window, the new window will get to top at all XP-
partners.  
The driver changes the cursor position or changes the text of the file; the changes will 
appear at XP-partner side.  
(During the pair programming session the navigator or visitor is not able to edit the 
document or to change the cursor position.)  
The driver or navigator fold or unfold an editor region, the folding or unfolding event is 
shown at all XP-partners. The event only effects those XP-partners, which have enabled 
folding event in the Eclipse preferences.  
The driver selects a text; the text selection is shown to all other XP-partners in blue 
colour.  
The navigator selects a text; the text selection is shown in green colour to the other XP-
partners.  
A visitor has the speech right, and then a text selection is shown in brown colour at all 
other XP-partners.  
If a driver or a navigator scrolls up or down in the editor window, the scrolling event is 
performed on the other XP-partner side as well.  

 
 
 
 



 
Screen example: 

 

On this screenshot you can see on the top the view of the navigator and at the bottem the view 
of the driver 

Keep in mind:  

If the driver choose a different editor for opening a Java file, while a session is running, the 
file will not be opened on the XP-partner side. At the moment the plug-in Java editor only 
supports Java files. So if you open a file of a different format, you can not share it within a 
pair programming session. 

Source consistence: 

To keep the Java sources consistent, it is not recommended to make a checkout or check in to 
CVS or other version management system during a session. After the session is closed either 
the driver or the navigator should check in the changed java documents. The other XP-
partners should only update the project data if needed. 



2.7 PlayBackView 
You can start the PlayBackView by using the menu Window > ShowView > Other > XecliP 
> PlayBackView. If you have chosen the XecliP perspective, the view can be found on the 
bottom group of the window. 

The PlayBackView can be used to start a search for recorded sessions and to playback a 
recorded session. (SessionDefinitionDialog). To use the PlayBackView it is necessary to 
connect to a server. Because recorded sessions are stored at the server. 

PlayBackView (at start): 

To search for recorded session, which are storred at the server, you should push the "Session 
log..." button first. 
A new dialog will open. Here you can search for recorded sessions. (SessionlogDialog).  

 

PlayBackView (playback is running): 

After you have selected a session for playback at the SessionlogDialog, you will come back to 
the PlayBackView, where now all controls are enabled for playback. 

 

At the PlayBackView you will see at the "Session data" group the name and the date of the 
recorded session.  

By pushing the "Play"  button the session playback will start. 

The speed of the playback can be determined by the scaler below. Move it to the right to speed 
up the playback. Move it to the left to slow down the playback speed.  

To stop the playback for a while you can push the "Stop"  button on the player control.  



At the "Session progress:" group you will see the progress of the session playback.  

While the session playback is running, you will see the following events which took place at 
the original session:  

editor open  
editor text changes and text selections  
editor save  
editor close  
chat events (at chat views)  
switch role (at session view)  
joining or leaving visitors (at session view)  

After you have started the session playback, the session is visible at the session view 
(SessionView). The name of the session is extended by the text "(PlayBack)". So you can 
identify the playback session easy.  

Keep in mind: 

While a playback of a session is running, you can not open another session, accept an 
invitation or join another session. Therefore the most menus on UserView and SessionView 
are disabled.  

By pushing the "Cancel" button, you can leave the session playback. The temporary project 
folders will be deleted. You are now free to create or participate on other sessions. 



2.8 Sessionlog Dialog 
At Sessionlog Dialog you can search for recorded sessions on the server you are connected to 
and select one session for playback. 

 

To search for all available sessions on the server you can just push the "Search" button. In 
order to limit the number of results and not to wait to long for an answer from the server, it is 
recommended to enter some search criteria. 

At the fist upper group you can enter a session name and a user name. The session name must 
not be complete. The text you enter can be a part or can be the whole session name you know. 
The user name is used to identify all session where the user has participated as driver or 
navigator. Here you can enter the whole name or as far as you know only a part of the name. 

At the second upper group you can enter a date from and a date to. All sessions which have a 
recording date between these two dates are included in the result. If you enter only a date 
from, all session form that date on and up today are searched. If you enter only a date to, all 
available sessions in the past which are older than the date to are included in the result. 

Your can enter the search criteria in any combination you like. If you enter more than on 
criteria all the criteria must apply to the session. 

To start the search you can push the "Search" button on the bottom of the dialog. While the 
searching is in progress and the data are transferred to you, you will see a progress monitor in 
the middle of the dialog. When all data have arrived, the progress monitor will disappear and 
the result will be shown in the combo box at the bottom of the dialog. If no session could be 
found, which matches you search criteria, the combo will only contain the text "no result". 

From the combo box you can choose on of the session for playback. If you want to start the 
session playback, you should push the button "Start Session". In order to start the session, the 
session log data are requested from the server. While the session log data are transfered to 
you, you will see a progress monitor. After you workspace have been initialized for playback, 
you will come back to the PalyBackView (PlayBackView). 

 



 
 
 
 
If the session you want to see, is not in the result combo box, you can alter the search criteria 
to perform an other search. 

To leave the dialog and not to playback any session, press the "Cancel" button. 



2.9 XecliP Preferences (Editing Groups) 
By a right click on the server or a group in the User View (“Organize Groups“) or by 
Window > Preferences > XecliP you enter the XecliP Preference Page. Here you can create 
and edit groups to organize your XP-partners shown in the User View. 

 

Add Groups 

To add a new Group enter the name in the combo-box on the top of the dialog and press the 
“add”-Button. 

Remove Groups 

To remove a group select it in the combo-box on the top of the dialog and press the “remove” 
button. 

Edit Groups 

The list on the right side of the dialog shows you all online XP-partners who can be added to a 
group. If you want to add a user select the group in the groups-combo-box or add a new one, 
select the user in the right list (“Please select a user”) and press the upper arrow-button  . 
The user will be listed in the left Groups-member-list. Please note: Only users with status 
“online”, in “session” or “busy” are able to be added to a group.  
To remove a user from a group select the group, then select the user in the left “Group 
members”-list and press the lower arrow-button  . 
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3.1 Create A Session 
After you have connected to the server (QuickConnect) you can choose a user for the pairing 
session. There are three possibilities to open the SessionDefinition Dialog (SessionDefinition 
Dialog):  

Choose a user in the UserView (UserView) and right-click. Choose "Invite as navigator 
to session". The SessionDefinition Dialog will appear.  
Choose from the menu:Xeclip > New session. The SessionDefinition dialog will 
appear.  
Choose a user at the Session Wizard Result Dialog (SessionWizard). After the dialog 
gets open you can choose a xp-partner from the combo box. After pressing the OK 
button the SessionDefinition Dialog will appear.  



3.2 Working in Pairprogrammingsession 
 
3.2.1 Act as Driver 

Before the session 

To become the driver in a session, you must first initiate a session. The person who initiates a 
session is always the driver in the beginning. To start a session, you invite another user, either 
by selecting "Invite as navigator to session" from the context menu in the user view, or by 
selecting "New Session" from the XecliP main menu.  

 

    

After filling out the session definition dialog, the user you invited as navigator will be 
informed about your invitation, and if she accepts, the session will be initiated. Due to 
workspace synchronization, this may take a while.  

 
 
 
Within the session 

Once the session is ready, you are the driver for this session. You can now do any of the 
following:  

Open files for editing, just as if working alone on a project  
Edit file, also just as usual  
Write to the driver/navigator chat  
Write to the visitor chat  
Request a role switch (see below)  
Grant speech right to a visitor (see below)  
Close the session  

Among the actions you can only do in a pair programming session, one is to request a role 



switch. A role switch must be accepted by your partner. You may request to switch roles in 
the current session by clicking the switch role button in the top left corner of your Eclipse  

 

If the navigator accepts the role switch, a message is displayed and you are now navigator.  

 

Another action which can only be performed by the driver is to grant speech right to a visitor 
who has requested it. A visitor who has requested speech right is marked in the session view 
with a blinking black background.  

You can accept or reject the visitors request for speech right by selecting the corresponding 
entry from the context menu you get by right-clicking on the visitors name in the session 
view. This will allow the visitor to post into the driver/navigator chat.  

 

At any time after granting the speech right, you can also revoke it from the visitor by selecting 
the revoke entry from the same context menu.  

When you are done you can close the session by right-clicking your session in the session 
view and selecting "close session".  



  

 
 
 
After the session 

After the session is closed you will be prompted two options, to either to leave the session 
without rollback all changed content to the previous state or to leave everything as it is. You 
should only use rollback if you don’t need anything that was coded while you were in session 
with your XP partner. Remember that the changes are not committed to your version control 
system automatically after the session ends. It is a wise idea to coordinate who should commit 
the changes before ending the session.  

 



3.2.2 Act as Navigator 

Before the session 

To join a session as navigator you must have two things: 

1. an invitation from someone else  
2. a checked-out CVS-project matching the project in the invitation  

If you get an invitation you will notice the yellow background 
color in the user view, in the picture Franka invites us to a 
session. 

 
 
 
Double-click the name and you see the invitation details: 

 
You may accept or deny the invitation. If you deny it, you can enter some additional 
information why you don’t want to start a session. Your answer is then displayed on the 
driver’s side. 

If you accept, the session will be created within some seconds - 
depending on how far your project-versions are divided. After 
that the session-view will be updated with your session. 
The small icon in front of your name tells you about your role 
in the session. Currently franka is Driver (indicated by the 
steering wheel) and dominik Navigator (indicated by the 
compass rose). 

 
 
 
 
 
Within the session 

The driver opens a .java-Document from the current project. This is opened on the 
participant’s side. While the driver is by design the only one who can change something 
within the document the XecliP-plugin helps the Navigator to do his guiding job in multiple 
ways: 



you can see the text changes, cursor and scroll-movements the driver currently makes 
in the editor window (note that only documents which are part of the current project will 
be transferred) 
 
you can select text with your mouse-cursor at any time, the selection will be displayed 
on every corresponding editor from other session participants in the same color you use

 
 
you can chat in the driver/navigator chat – this chat is reserved for the two pair 
programmers or chat with visitors to answer questions or discuss annotations 

 
 
you may request to become the driver in the current session by clicking the switch role 
button in the top left corner of your eclipse  

  
 
If the driver accepts the role switch a message is displayed and you are now driver.  

 
 

When you are done you can close the session by right-clicking your session in the session 
view and selecting "close session".  



 

 
 
 
After the session 

After the session is closed you will be prompted two options, to either to leave the session 
without rollback all changed content to the previous state or to leave everything as it is. You 
should only use rollback if you don’t need anything that was coded while you were in session 
with your XP-Partner. Remember that the changes are not committed to your version control 
system automatically after the session ends. It is a wise idea to coordinate who should commit 
the changes before ending the session. 

 



3.2.3 Act as visitor 
XecliP provides the option to act as a visitor in an actual existing session of two XP-partners 
to another users. Therefore in the SessionView the user can join in the session. With a right-
click on the session name in the session view a context menu opens and the user can place the 
request. 

 

Then the visitor has to wait until the driver has accept his requestto join session as a visitor. 

 

As soon as the driver has accepted, the data transfer and the update of the visitors workspace 
starts. The visitor receives the data from the actual project like the driver and navigator. 

It is possible, that several visitors join a session. The visitors are able to communicate to each 
other within the visitor chat. 

By the option get "speech right" in the driver/navigator chat and the confirmation by the 
driver, the visitor gets some more rights. 

 

Now the visitor is allowed to mark text in the driver/navigator editor and to write in the 
driver/navigator chat. 

 
 
 
 
 
 
 
 
 
 



 
 
 
 
 
 
After the session is closed there will be shown two options to you, either to leave the session 
without rollback of  all changed contents to the previous state of the workspace or to hold onto 
the workspace as it is. You should only use rollback if you don’t need anything tcoded while 
you were in session with your XP-Partners. Remember that the changes are not committed to 
your version control system automatically after the session ends. It is a wise idea to make an 
arrangement about who should commit the changes before terminate the session. 



3.2.4 SwitchRole 
At the main toolbar and the XecliP menu you can find a toggle button, to initiate a switch role 
request ( ) and to cancel a switch role request ( ). When you are in a pairing session you 
can switch the role from driver to navigator or vice versa. The other user will see the request 
at the SessionView which will get the focus: 

 

This example shows a request from the navigator franka. 

To accept this request right-click the purple marked user and a popup menu will open. Here 
you can find the option to accept the switch role request 

 

The switch role requester can take back the request by pressing the "switch role cancel" button 
(toggle button). The purple marked requester in the SessionView will vanish. 



3.3 Close a session 
If you want to leave the session as a visitor simply select the entry “leave session” in the 
session view’s popup-menu by right clicking the session’s label. 

 

Leaving a session as a driver or navigator also means to close the session. This will cause all 
other participants to leave the session too. They will be informed by an accordant message. To 
close the session choose the entry “close session” in the session view’s popup-menu by right 
clicking the session’s label. 

 

Your workspace has been changed by means of the session. After you have left, you want to 
decide whether to keep the changes or rollback. You choose the corresponding setting from 
the upcoming dialog and press ok. 

 

 
 
 
 
 
 



3.4 Communicating with XP-Partners 

Before the session 

You have to enter a session before you can use the chat. 

Within the session 

While in session you can use the XecliP chat views to chat with the session participants. There 
are two types of chat views: 
Driver/Navigator Chat and Visitor Chat 

 

While the Visitor Chat can be used by every session participant the Driver/Navigator Chat 
may only be used by Driver or Navigator. However it is possible for a visitor to use the 
Driver/Navigator Chat too, if he was granted speech right. See Act As Visitor for details 
about speech right. 

If you have used a chat before you don't have to learn anything new. Just type in your message 
in the input line and press Enter or click on the button "Send". Your message will be send to 
all participants and displayed in the output window above. 

If you start typing a notice is displayed on the participants side  (e.g. in this 
picture "franka is typing") 

 

 
 
 
 
 



3.5 Create a user profile 
By using the  button at the user view´s menu (UserView) you can start the user profile 
input dialog. Within this dialog each user can give some details about his person (name, 
address etc.), personal skills and projects, he has participated. The user can also load a picture.

The skills are necessary and helpful to get some more informations about yourself and later 
this statements help another user to find a partner for a common procjet. For example you can 
search with the session wizard for users with special skills. 

 

 
 
 
 
 
 
 
 



3.6 Organize your XP-Partners. 
As described in previous chapters, all users are shown in the UserView. You may find it 
useful to organise them. 

 

There are two ways to do this. First you can group users by topics you can set individually. 
Right click on the server or a group in the User View (“Organize Groups“) or select Window 
> Preferences > XecliP and enter the XecliP Preference Page.  

The other option is to filter users by attributes like name or online status. To do this utilize the 
filter function as described on the page about the User View.  



3.7 Playback a Session 
For a session playback you need to open the PlayBackview. You can start the PlayBackView 
by using the menu Window > ShowView > Other > XecliP > PlayBackView. If you have 
chosen the XecliP perspective, the view can be found on the bottom group of the window. 

The PlayBackView can be used to start a search and to playback a recorded session. 
(SessionDefinitionDialog). To use the PlayBackView it is necessary to connect to a server. 
Because recorded sessions are stored at the server. 

PlayBackView (at start):  

 

To search for recorded session which are storred at the server, you should push the "Session 
log..." button first. A new dialog will open. 

Sessionlog Dialog:  

 

To search for all available sessions on the server you can just push the "Search" button. In 
order to limit the number of results and not to wait to long for an answer from the server, it is 
recommended to enter some search criteria. 

At the fist upper group you can enter a session name and a user name. The session name must 



not be complete. The text you enter can be a part or can be the whole session name you know. 
The user name is used to identify all session where the user has participated as driver or 
navigator. Here you can enter the whole name or as far as you know only a part of the name. 

At the second upper group you can enter a date from and a date to. All sessions which have a 
recording date between these two dates are included in the result. If you enter only a date 
from, all session form that date on and up today are searched. If you enter only a date to, all 
available sessions in the past which are older than the date to are included in the result. 

Your can enter the search criteria in any combination you like. If you enter more than on 
criteria all the criteria must apply to the session. 

To start the search you can push the "Search" button on the bottom of the dialog. While the 
searching is in progress and the data are transferred to you, you will see a progress monitor in 
the middle of the dialog. When all data have arrived, the progress monitor will disappear and 
the result will be shown in the combo box at the bottom of the dialog. If no session could be 
found which matches you search criteria, the combo will only contain the text "no result". 

From the combo box you can choose on of the session for playback. If you want to start the 
session playback, you should push the button "Start Session". In order to start the session, the 
session log data are requested from the server. While the session log data are transfered, you 
will see a progress monitor.  
If the session you want to see, is not in the result combo box, you can alter the search criteria 
to perform an other search. 
To leave the dialog and not to playback any session, press the button "Cancel". 

PlayBackView (playback is running): 

 

After the session log data have arrived, your workspace will be set up with the session data 
and you will see one or more temporary projects in you workspace. The name of the project 
folders begin with "PlayBackProject". 

For playback all controls are now enabled at PlayBackView. 

At the PlayBackView you will see at the "Session Data" group the name and the date of the 
recorded session. 

By pushing the "Play"  button the session playback will start. The speed of the playback 
can be determined by the scaler below. Move it to the right to slow down the playback speed. 
Move it to the left to speed up the playback. To stop the playback for a while you can push the 
"Stop"  button on the player control. At the "Session progress:" group you will see the 
progress of the session. 

While the session playback is running, you will see the following events which took place at 



the original session: 

editor open  
editor text changes and text selections  
editor save  
editor close  
chat events (at chat views)  
switch role (at session view)  
joining or leaving visitors (at session view)  

After you have started the session playback, the session is visible at the session view. The 
name of the session is extended by the text "(PlayBack)". So you can identify the playback 
session easy.  

Keep in mind: 

While a playback of a session is running, you can not open another session, accept an 
invitation or join another session. Therefore the most menus on UserView and SessionView 
are disabled. 

By pushing the "Cancel" button, you can leave the session playback. The temporary project 
folders will be deleted. You are now free to create or participate on other session. 



3.8 Running XecliP-Server 
There are two ways to start the xeclip-Server-Component. After the server is started it will 
listen on the default port 2631 for incoming XecliP-Client-Connections. 

The easiest way to run the XecliP-Server is to use the .jar-Distribution.: Download 
XecliPServer.jar and put it in an dedicated folder. Change to that directory and run 

java -Xmx500m -jar XecliPServer.jar 

On first start multiple files and folders will be created. 
A note to Windows Users: It's a good idea to create a shortcut for that. 
<your-jre-bin>\java.exe -jar "<your-path-to-xeclipServerJar>\XecliPServer.jar"  
If you have loaded the project into you eclipse workspace and you want to start it within 
your eclipse environment, you have to select the class de.feu.xeclip.server.StartServer 
and then select "Run as" > "Java Application"  




